Toilet from hell continues… water supply

After the thing leaking, replacing the flapper, valve (FLUIDMASTER 400), resealing the tank… it doesn’t fill worth a hoot. I checked the valve but the water doesn’t shoot up into a cup like the video shows to clean the valve. Barely dribbles out. I’m guessing either the valve to control the water to the toilet is bad or the water supply mixer valve (? not sure of what you call it) to the control valve is not getting thru as it should.

 
 

It is an older (80’s) adjustable valve that uses the hot water supply to fill the tank. I looked at it and it’s corroded, and the cold/hot mix valve on the top broke when I tried to turn it. The concept of using hot water to fill the tank is not really feasible, because the hot water in the line is cold and take a few gallons of running just to get hot, so it doesn’t really prevent the tank from sweating in the warmer weather.

 
 

Should I just use the cold water supply line to supply the tank?

 
 

I’m rather afraid to turn the water to the house off and mess with the hot water line. Is it tied into the hot water baseboard heating system? I don’t want to get air in the system since I don’t know how to purge the air from the lines… or is it OK as it is separate from the HWBB system?

 
 

No, I haven’t checked the toilet water supply valve yet for proper flow. Do these things go bad or need repacked?

Advertisements
Standard

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s